X-Chat crashes when closing a channel

Discussion about the official XChat for Windows.

X-Chat crashes when

Postby ArendJ » 14 Jun 2004 13:01

Hi foks,

With the last several releases from X-Chat I'v got the problem that, when I close a channel, X-Chat Crashes.

The crash only happens when one or more persons post a message between the moment you have joined the channel, and close it.

This happens on my computer (W2k) but also at the computers of serveral friends (WXP Home Ed.) We are all logged in as IRC operator, and not using any scripts.

Hopefully someone can help me with this :cry:

Regards,
ArendJ
ArendJ
 

Postby tapeworm » 15 Jun 2004 02:50

Oh my, I was thinking that only I have this problem. I'm using a small selfmade autoident perl script, but the bug appears even when it's not loaded. It's really happening since 2.0.3 or 2.0.4, can't tell exactly and I don't have the time to test all 2.0.x versions. The bug is pretty annoying, because I idle on two different networks and summary 18 channels, and when the connection to one of the servers drops or i get kicked from one of the channels xchat crashes and blocks the system, using 99% of the CPU resources until the xchat.exe process is closed manually. I've seen this happening only on my computer, but it looks like i'm not alone in this :? .
I'm using WinXP sp1 latest patches, windows themes disabled.

P.S. Nice forum, the xchat supporters needed it, imho.
User avatar
tapeworm
 
Posts: 4
Joined: 15 Jun 2004 02:31
Location: Bulgaria

Postby peterz » 15 Jun 2004 04:30

Windows support is really non-existant, you'll have to debug it yourself :)

Instructions here: http://xchat.org/gdb/
User avatar
peterz
 
Posts: 1035
Joined: 09 Jun 2004 13:51
Location: Australia

Postby tapeworm » 15 Jun 2004 14:23

Ok, when will be the debug xchat.exe for 2.0.9 available?
User avatar
tapeworm
 
Posts: 4
Joined: 15 Jun 2004 02:31
Location: Bulgaria

Postby peterz » 15 Jun 2004 15:17

I don't think I'll make one. Can you do with 2.0.8c?
User avatar
peterz
 
Posts: 1035
Joined: 09 Jun 2004 13:51
Location: Australia

Postby tapeworm » 15 Jun 2004 21:17

So here is what i get with 2.0.8c

Code: Select all
WARNING: Stack unwind information not available. Following frames may be wrong.
ntdll!RtlpNtEnumerateSubKey+0x64d2
ntdll!RtlSizeHeap+0x1cfa
ntdll!RtlFreeHeap+0xf9
msvcrt!free+0xc3
xchat!history_up+0x1da
xchat!tree_foreach+0x24
xchat!free_userlist+0x18
xchat!clear_user_list+0x11
xchat!clear_channel+0x68
xchat!tcp_sendf+0x4ed
xchat!tcp_sendf+0x1822
xchat!tcp_sendf+0xda1
kernel32!ResetEvent+0xa
xchat!g_io_channel_close+0x758
xchat!unblock_source+0x119
xchat!g_main_context_dispatch+0x2c
xchat!g_main_context_dispatch+0x1dc
xchat!g_main_loop_run+0x127
xchat!gtk_main+0x99 [c:\cygwin\home\peter\gtk2\src\gtk\gtk\gtkmain.c @ 1095]
xchat!fe_main+0x5
User avatar
tapeworm
 
Posts: 4
Joined: 15 Jun 2004 02:31
Location: Bulgaria

Postby peterz » 17 Jun 2004 03:38

Well I'm at a loss, I just don't know.

Any Windows experts around?

It doesn't seem to crash on my system. Is this the crash when you get disconnect by the server?
User avatar
peterz
 
Posts: 1035
Joined: 09 Jun 2004 13:51
Location: Australia


Return to XChat for Windows

Who is online

Users browsing this forum: No registered users and 3 guests